Cloudflare Outage
Incident Report for Avatar New York
Postmortem

Below is a link to cloudflare’s postmortem on yesterday’s outage:

Cloudflare outage caused by bad software deploy (updated)

Posted Jul 03, 2019 - 10:08 UTC

Resolved
Resolved - Cloudflare has resolved the issue and services have resumed normal operation.
Jul 2, 14:57 UTC

Description:
Major outage impacted all Cloudflare services globally. We saw a massive spike in CPU that caused primary and secondary systems to fall over. We shut down the process that was causing the CPU spike. Service restored to normal within ~30 minutes. We’re now investigating the root cause of what happened.
Posted Jul 02, 2019 - 15:04 UTC
Monitoring
Monitoring - Cloudflare has implemented a fix for this issue and is currently monitoring the results.

We will update the status once the issue is resolved.
Jul 2, 14:15 UTC
Posted Jul 02, 2019 - 14:25 UTC
Investigating
Cloudflare is experiencing an outage. See details below:

https://www.cloudflarestatus.com/

Investigating - Cloudflare is observing network performance issues. Customers may be experiencing 502 errors while accessing sites on Cloudflare.

We are working to mitigate impact to Internet users in this region.
Posted Jul 02, 2019 - 14:00 UTC
This incident affected: Websites, Rackspace Production Infrastructure, AWS Production Infrastructure, Staging Environment, and CloudFlare CloudFlare.com.