Outages in AWS
Incident Report for Avatar New York
Postmortem

From cloudflare’s incedent page:

https://www.cloudflarestatus.com/#past-incidents

Jun 24, 2019

Route Leak Impacting Cloudflare

Resolved - Traffic levels have returned to normal now that the route leak has been fixed. We are now marking this incident as resolved.
Jun 24, 13:02 UTC

Monitoring - The network responsible for the route leak has now fixed the issue. We are seeing improvement and are continuing to monitor this before we consider this issue resolved.
Jun 24, 12:42 UTC

Update - This leak is impacting many internet services including Cloudflare. We are continuing to work with the network provider that created this route leak to remove it.
Jun 24, 12:34 UTC

Update - We are continuing to work on a fix for this issue.
Jun 24, 11:43 UTC

Identified - We have identified a possible route leak impacting some Cloudflare IP ranges and are working with the network involved to resolve this.
Jun 24, 11:36 UTC

Investigating - Cloudflare is observing network related issues.
Jun 24, 11:02 UTC

Posted Jun 24, 2019 - 13:39 UTC

Resolved
Cloudflare: "Resolved - Traffic levels have returned to normal now that the route leak has been fixed. We are now marking this incident as resolved.
Jun 24, 13:02 UTC"
Posted Jun 24, 2019 - 13:37 UTC
Monitoring
Cloudflare: "Monitoring - The network responsible for the route leak has now fixed the issue. We are seeing improvement and are continuing to monitor this before we consider this issue resolved.
Jun 24, 12:42 UTC"
Posted Jun 24, 2019 - 12:53 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 24, 2019 - 11:17 UTC
Update
This appears to be an issue with cloudflare. We have confirmed non-cloudflare sites were not affected. Cloudflare is currently working on resolving the issue:

"Network Performance Issues Subscribe
Investigating - Cloudflare is observing network performance issues.

We are working to mitigate impact to Internet users in this region.
Jun 24, 11:02 UTC"
Posted Jun 24, 2019 - 11:08 UTC
Investigating
We are investigating reported outages in our AWS evironments. We will update you as soon as we have more information
Posted Jun 24, 2019 - 10:53 UTC
This incident affected: Websites, Rackspace Production Infrastructure, AWS Production Infrastructure, Staging Environment, CloudFlare CloudFlare.com, CloudFlare CloudFlare APIs, CloudFlare EWR - Newark, New Jersey, USA, CloudFlare DFW - Dallas, Texas, USA, CloudFlare ORD - Chicago, Illinois, USA, CloudFlare LHR - London, England, CloudFlare LAX - Los Angeles, California, USA, CloudFlare ATL - Atlanta, Georgia, USA, and CloudFlare IAD - Ashburn, Virginia, USA.